TP-027, Jerry Garcia / David Grisman wins a Writer's Choice Award from Myles Astor of Positive Feedback Online

Author Topic: excessive hiss on playback sudddenly  (Read 3509 times)

Offline OOF

  • Newbie
  • *
  • Posts: 1
    • View Profile
excessive hiss on playback sudddenly
« on: July 17, 2010, 03:40:07 PM »
My Revox PR99 II has been running beautifully but now is creating a lot of hiss on playback.  No hiss when monitoring thru SOURCE, only on REPRO.  Demag-ed, cleaned heads, the machine is biased correctly, switched out tapes, etc.  It's even on both channels, and there is some very low-level, dark random popping on the right side only. 
I've opened it up and don't see anything obvious like a blown cap (I'm thinking the power supply, since it's the same on both channels).
the unit has not been recapped and was sitting in storage for a long tim,e before I got it and started using it about 3 months ago.  Up until now it has been performing beautifully.

Glad to be new to this forum, and thanks, in advance, for any insight,
David

Offline Ki Choi

  • Sr. Member
  • ****
  • Posts: 314
    • View Profile
Re: excessive hiss on playback sudddenly
« Reply #1 on: November 08, 2010, 12:33:14 PM »
Hi David:

It seems no one had replied to your original post from last summer...sorry it happend.

Your hissing and random popping sound point to magnetized head...  Although you had stated you had already demaged the head, if you used anything other than strong Anis Tape Head Demag device, it is more than likely it is still magnetized.  You can play the same tape on a different machine for the hissing and popping.  If you hear it again, then you know your head needs the Anis demaging.

I have seen Studer machines with one of the rail voltages for the head preamp go bad and cause magnetization of the head.  You should double check to make sure you have properly working head preamp.

Ki
Ki Choi

Offline docb

  • Administrator
  • leader in spreading disinformation
  • *****
  • Posts: 1345
    • View Profile
    • Bottlehead Corp.
Re: excessive hiss on playback sudddenly
« Reply #2 on: November 08, 2010, 01:25:54 PM »
Yup I agree, that little preamp behind the headblock can really wallop a playback head with a pulse that will magnetize it badly.
Dan "Doc B." Schmalle
President for Life, Bottlehead Corp.
Managing Director - retired, The Tape Project